中国自动化学会专家咨询工作委员会指定宣传媒体
免费注册 登录 广告服务 | 客服中心
您现在所在的是:

欧姆龙OMRON

抖音 西门子减速电机 德嘉 台达 英威腾 泓格论坛 西门子 我和LOGO!有个约会 FLIR红外热像论坛 【有奖活动】英威腾 “Ni美国国家仪器 “PLC发展趋势大讨论”活动圆满结束 cc-link图文征集活动 西门子SMART LINE V3
工控论坛首页 欧姆龙OMRON → 浏览主题: 请教,欧姆龙模拟量4-20MA和0-20MA转换的变量是一样吗
发表新帖 回复该主题
回帖:29个,阅读:290 [上一页] [1] [2] [3] [下一页]
* 帖子主题:

请教,欧姆龙模拟量4-20MA和0-20MA转换的变量是一样吗

分享到
599
怪怪FqJQbsJp
文章数:43
年度积分:123
历史总积分:599
注册时间:2016/1/10
发站内信
发表于:2020/7/9 17:05:26
#0楼
现场一压力传感器,0-200KG,放大器是4-20MA,如果模拟量是3000,转换后实际是100KG吗,同样,如果放大器是0-20MA,如果模拟量是3000,实际也是100KG吗。为什么,请帮忙分析一下,谢谢
75039
ZCMY 版主
文章数:44800
年度积分:2274
历史总积分:75039
注册时间:2004/3/16
发站内信
2018论坛贡献奖
2018春节活动(三)
2017论坛优秀版主
2017国庆活动(三)
2016论坛优秀版主
2015论坛优秀版主
2014论坛优秀版主
2014相约国庆
2013论坛优秀版主
2012论坛优秀版主
2011论坛贡献奖
2010年论坛优秀版主
发表于:2020/7/9 17:15:41
#1楼
呵呵;一个最重要的条件你没讲;模块输入是可以设置量程是0~20mA还是4~20mA;这个量程设与你的传感器一样,减少运算;
599
怪怪FqJQbsJp
文章数:43
年度积分:123
历史总积分:599
注册时间:2016/1/10
发站内信
发表于:2020/7/9 17:22:13
#2楼
回复 #1楼 ZCMY
你好,我没有听明白,我是说都是0-200公斤的压力传感器,只是放大器不同,选0-20MA的和4-20MA的是不是都是模拟量除以30,另外,软件设置变更了的,4-20MA放大器对应4-20MA,0-20MA放大器对应0-20MA,谢谢
[此贴子已经被作者于2020/7/9 17:51:13编辑过]
6487
蜀中之首
文章数:4382
年度积分:1754
历史总积分:6487
注册时间:2018/5/27
发站内信
发表于:2020/7/9 18:10:22
#3楼
只换了放大器?原来是100kg,现在肯定不是100kg
75039
ZCMY 版主
文章数:44800
年度积分:2274
历史总积分:75039
注册时间:2004/3/16
发站内信
2018论坛贡献奖
2018春节活动(三)
2017论坛优秀版主
2017国庆活动(三)
2016论坛优秀版主
2015论坛优秀版主
2014论坛优秀版主
2014相约国庆
2013论坛优秀版主
2012论坛优秀版主
2011论坛贡献奖
2010年论坛优秀版主
发表于:2020/7/9 19:42:54
#4楼
如果你的PLC模拟量模块设成0~20MA与4~20mA对应的数字量都是0~6000的话,在PLC模块量程设定与你传感器信号相符合的前提下,你读出的转换量3000都对应的是100KG,不同之处是二个传感器在100KG时对应的电流输出值不同,一个是10mA,一个是12mA;
599
怪怪FqJQbsJp
文章数:43
年度积分:123
历史总积分:599
注册时间:2016/1/10
发站内信
发表于:2020/7/9 20:44:15
#5楼
回复 #4楼 ZCMY
谢谢,我现在现场的问题是和标准的压力计有误差,我PLC显示10Kg,标准压力计为12Kg,pLc显示12kg,标准压力计显示15KG,不成线性关系,不知是压力传感器有问题还是算法有问题,我采用的是4~2OmA的放大器,公斤数的换算是模拟量除以3O
75039
ZCMY 版主
文章数:44800
年度积分:2274
历史总积分:75039
注册时间:2004/3/16
发站内信
2018论坛贡献奖
2018春节活动(三)
2017论坛优秀版主
2017国庆活动(三)
2016论坛优秀版主
2015论坛优秀版主
2014论坛优秀版主
2014相约国庆
2013论坛优秀版主
2012论坛优秀版主
2011论坛贡献奖
2010年论坛优秀版主
发表于:2020/7/9 21:23:54
#6楼
测量电流值看对不对;
6487
蜀中之首
文章数:4382
年度积分:1754
历史总积分:6487
注册时间:2018/5/27
发站内信
发表于:2020/7/9 22:18:26
#7楼
1.将PLC设置4-20ma后,PLC要重启
2.读到的数值直接除以30?要统一数制
3.传感器问题,或放大器问题,PLC模数问题都可能
6487
蜀中之首
文章数:4382
年度积分:1754
历史总积分:6487
注册时间:2018/5/27
发站内信
发表于:2020/7/10 9:49:54
#8楼
还一个,压力表接在放大器上?压力表是否有问题
压力表自带传感器,二个传感器安装的位置是否有较大压力差
599
怪怪FqJQbsJp
文章数:43
年度积分:123
历史总积分:599
注册时间:2016/1/10
发站内信
发表于:2020/7/10 11:15:27
#9楼
回复 #7楼 蜀中之首
你好,这个都统一了的,和我计算器算的结果也是一样,我只是除以30的立场不是很坚定,所以有此一问,重启PLC那都不知道有多少次了,设备验收就这压力测试没通过,已试验3个月了,当时也没有做压力校验,现在说有问题,准备联系厂家再发一套试试
工控学堂推荐视频:

关于我们 | 联系我们 | 广告服务 | 本站动态 | 友情链接 | 法律声明 | 非法和不良信息举报

工控网客服热线:0755-86369299
版权所有 中华工控网 Copyright©2020 Gkong.com, All Rights Reserved

78