中国自动化学会专家咨询工作委员会指定宣传媒体
免费注册 登录 广告服务 | 客服中心
您现在所在的是:

人机界面

抖音 西门子减速电机 德嘉 台达 英威腾 泓格论坛 西门子 我和LOGO!有个约会 FLIR红外热像论坛 【有奖活动】英威腾 “Ni美国国家仪器 “PLC发展趋势大讨论”活动圆满结束 cc-link图文征集活动 西门子SMART LINE V3
工控论坛首页 人机界面 → 浏览主题: 求助 威伦TK6070IK和永宏PLC无法通讯
发表新帖 回复该主题
回帖:14个,阅读:137 [上一页] [1] [2] [下一页]
* 帖子主题:

求助 威伦TK6070IK和永宏PLC无法通讯

分享到
2976
Tivian
文章数:130
年度积分:359
历史总积分:2976
注册时间:2006/5/21
发站内信
发表于:2020/4/6 10:54:32
#0楼
求助,一个威伦TK6070IK,无法和永宏PLC通讯,首先485,COM2的12接永宏的CB55的485接口,通讯参数设置成一样的,无法通讯,只是接收和发送灯同时闪,485通讯板是好的,可以连接电脑编程,然后用232,接永宏的PROT0,也无法通讯,线也换过.按说应该是屏的通讯有问题,但是用三菱的PLC的422,一设置好,就能通讯,换了软件版本,从EB8000的433,465.466都一样的,485通讯时能串口工具检测屏的发送数据如图片,到底是哪里有问题,也更新了屏的固件
附件 QQ图片20200407102111.jpg
附件 QQ图片20200407102200.jpg
[此贴子已经被作者于2020/4/7 10:23:51编辑过]
1920
18002767052
文章数:83
年度积分:211
历史总积分:1920
注册时间:2014/6/17
发站内信
发表于:2020/4/6 11:44:56
#1楼
默认站号不对,
74541
ZCMY 版主
文章数:44512
年度积分:1776
历史总积分:74541
注册时间:2004/3/16
发站内信
2018论坛贡献奖
2018春节活动(三)
2017论坛优秀版主
2017国庆活动(三)
2016论坛优秀版主
2015论坛优秀版主
2014论坛优秀版主
2014相约国庆
2013论坛优秀版主
2012论坛优秀版主
2011论坛贡献奖
2010年论坛优秀版主
发表于:2020/4/6 12:15:16
#2楼
应当还是设置或通讯线的原因;
2976
Tivian
文章数:130
年度积分:359
历史总积分:2976
注册时间:2006/5/21
发站内信
发表于:2020/4/6 13:05:10
#3楼
以下是引用180027670522020/4/6 11:44:56的发言:
默认站号不对,
站号 屏是0  plc是1
此帖发自手机工控论坛
2976
Tivian
文章数:130
年度积分:359
历史总积分:2976
注册时间:2006/5/21
发站内信
发表于:2020/4/6 13:06:31
#4楼
以下是引用ZCMY2020/4/6 12:15:16的发言:
应当还是设置或通讯线的原因;
485两线 1.2互换线也不行 plc通讯板确实是好的
此帖发自手机工控论坛
27286
YXBK 版主
文章数:12977
年度积分:1829
历史总积分:27286
注册时间:2007/4/14
发站内信
2015论坛优秀版主
2015春节活动
2013论坛优秀版主
2012论坛优秀版主
发表于:2020/4/6 13:25:52
#5楼
感觉屏和PLC都没问题,重点检查一下参数设置和通讯线,线如果是自己焊接的要主要针脚排列顺序,最好是能把参数设置的界面截图上来,这样大家都可以帮你看一下有没有设置错误的。
大家一起学习
2976
Tivian
文章数:130
年度积分:359
历史总积分:2976
注册时间:2006/5/21
发站内信
发表于:2020/4/6 23:31:56
#6楼
附件 54F7E8A1-E563-4E8F-B2DB-F3DF60D9CB8B.jpg

附件 93BB0F10-6800-47BD-B99B-D71822547759.jpg
此帖发自手机工控论坛
2976
Tivian
文章数:130
年度积分:359
历史总积分:2976
注册时间:2006/5/21
发站内信
发表于:2020/4/6 23:32:58
#7楼
以下是引用YXBK2020/4/6 13:25:52的发言:
感觉屏和PLC都没问题,重点检查一下参数设置和通讯线,线如果是自己焊接的要主要针脚排列顺序,最好是能把参数设置的界面截图上来,这样大家都可以帮你看一下有没有设置错误的。
麻烦看看六楼 485通讯的设置
此帖发自手机工控论坛
16334
PLC-hmi
文章数:6704
年度积分:971
历史总积分:16334
注册时间:2010/8/19
发站内信
2018论坛热心网友
发表于:2020/4/7 8:33:17
#8楼
线的引脚错了不可能通讯成功的,自己测量一下
2976
Tivian
文章数:130
年度积分:359
历史总积分:2976
注册时间:2006/5/21
发站内信
发表于:2020/4/7 9:40:23
#9楼
回复 #8楼 PLC-hmi
485 2w 屏是接COM2 1 2脚,PLC这边是D+ D-,去年用过MT6070IH5和永宏PLC做过项目,那个就不用什么调试,设置好,最多调下线,就通讯上了,这个6070IK复杂了,换PLC,用232 485 怀疑是驱动问题,换了不同的编程版本都不行,但是和三菱PLC就没问题,还有朋友帮我远程看了的
工控学堂推荐视频:

关于我们 | 联系我们 | 广告服务 | 本站动态 | 友情链接 | 法律声明 | 非法和不良信息举报

工控网客服热线:0755-86369299
版权所有 中华工控网 Copyright©2020 Gkong.com, All Rights Reserved

140.4